Automatic Caps when editing an existing text


#1

They’re is a persistant bug in this application. When you try to edit an existing text, typically inserting a letter or a word inside the text, the fisrt letter you type is always capitalized… Very annoying…


#2

Hi philbel,

Thanks for the report - I presume you’re using SmartOffice on iOS? This is definitely annoying, and I’ve raised a feature request to look at this - our internal tracking ID for this is 695562.

Basically what happens is that we use the iOS soft keyboard to input charaters, but we handle insertion of characters ourselves. We don’t actually control which mode the keyboard is in (caps or otherwise) and the default behaviour for the soft keyboard is to start in ‘caps on’ mode when it is shown. We just accept the characters as we receive them from the keyboard, so the first character is always capitalised in the default case.

The keyboard behaviour is actually a system setting; if you go to Settings->General->Keyboard there is an ‘Auto Capitalisation’ setting, and that is what causes the keyboard to start in caps on mode. If you disable this setting then the keyboard will start with caps off.
Obviously this is a system-wide setting so would affect all applications, but in the short term it may be a usable workaround. It is not ideal but I did find it much less frustrating than starting in ‘caps on’ mode.

We’ll post on the forum periodically when we have new features and fixes in the pipeline so please check back for updates.

Thanks,
Pete


#3

We’ll be changing the iOS application to never automatically apply caps in the next release; that should be released sometime in the next month. We can provide access to a beta copy via the iOS 8 testflight application if anyone would like early access; please post a reply on this thread if you would.

We have a larger rework of the text input system (as there’s a few minor pieces that really don’t work like we’d ideally want) planned at some future point but I’m not yet sure when we will fit this in.