Cant open Smart Office 2


#1

Since I upgraded I’ve been unable to open Smart Office 2 on my iPad (iOS 9.3.1) at all! Any suggestions?


#2

Thank you for contacting us.

I do have one suggestion.

  • Close all open applications.
  • Turn off your device. (do not restart; power down)
  • Turn on your device.

If that doesn’t solve the problem, I’ll need additional details:

  • Did you upgrade your iOS or your SmartOffice, or both?
  • What error message are you getting (can you send a screen shot)?
  • Do you get a SmartOffice Splash screen when you try to launch?
  • What is the installed SO2 version in the lower left of the splash screen?

Thank you.

Ron
SmartOffice Support


#3

After upgrading my iPad, I also cannot open Smart Office 2. I have 2 years worth of sermons saved in Smart Office, and really need to get them. When I open Smart Office 2, I just get a blank white screen. HELP!


#4

Hi. Ron (who normally handles such questions) is on holiday. I’m filling in for him, so bear with me.

OK, so the first rule of storing stuff on your mobile devices is don’t store still just on your mobile devices. Always make sure you have everything backed up elsewhere - either on your desktop computer, or in the cloud.

Accordingly, it would have been a REALLY good idea to make sure you backed up before you did the upgrade, but it’s too late for that now.

So, before we do anything else, please connect your ipad to your computer and back everything up.

Have you tried Rons earlier suggestion, of turning the device off (really properly powering it down, not just putting it into standby), then starting it again?

That often solves the problem.

I’m not an iOS user myself, but I believe that when you connect the ipad to your desktop machine, you can see the files that applications have saved and can back them up. This would be a good way to get a copy safely onto your desktop.

Once you’ve safely extracted your files, then you can try uninstalling SO2 from your device, and then reinstalling it. Do NOT uninstall/reinstall without backing your files up first, as any files that that application has saved (i.e. all your sermons) may be lost!

HTH.

Robin


#5

Iamsamiam58 has been back in touch. Rebooting the device solved it!