Printing stopped all of a sudden /printer error


All of a sudden Smart Office started s a prime saying print error after I had just printed 3 other documents. I am using a Samsung Galaxy Pro Note 2 and a HP Photoshop D110 series printer. I even reinstalled the app and it still won’t print. I didn’t do anything different between documents. Please let me know if there is a fix to this problem as I really love the program and use it alot. Thank you.



I’m sorry you are having trouble. I have a few questions for you:

  1. Are you using the most recent version of SmartOffice (2.3.10) and if not, can you upgrade?

  2. What type of document was it, and what format? (i.e. Word DOC or DOCX; Excel XLS or XLSX)

  3. Can you tell me more about what you mean by “…started s a prime saying print error…”?

  4. Did the printer appear normally in the application when you tried to print?

  5. Can you send me a copy of the problem document? If you don’t want to publish it on the forum, I can send you my email address privately.

Thank you.

SmartOffice Support


1st off yes I ma using version 2.3.10, 2nd it was a word doc (.doc) but no other format would print either, also I tried to print the sample from the print room and that won’t print either. 3rd my first comment was suppose to say Smart Office 2 started saying print error after just printing 3 other documents, 4th when I hit print the printer room comes up like normal but no animation of the document printing out, I know my printer works as I printed with another application. And finally I cannot attach one of the documents I tried to print, it says new users cannot upload attachments. Thank you for your help with this problem.


We’re still not sure how we can help you. I’ve adjusted your user level so you should be able to upload the probelm document. Please try again.

It sounds like it might be a network problem, but it’s difficult to diagnose via forum postings.

Is your printer connected to a PC or Mac?
Have you tried rebooting the printer?
Have you tried closing all applicaitons on the mobile device, then rebooting?
Have you tried rebooting the workstation?

I’m sorry all I have for you are more questions.


Yes to all the above except for the Mac or PC, I am using a Samsung Galaxy Note Pro 2.
Here is the document I was trying to print. I even uninstalled and reinstalled the app and all it says when it comes to the print page is "print error " and shows the printer picture and a red “!” but no animation. Thanks for all the help, and I am as puzzled as you are with this one.

Baseball May.doc (61 KB)


I tried to open that document in MS Word on my PC and I got an error dialog box that advised: “a table in this file is corrupted”. I tried to “open and repair”, and I could see the document is a series of tables with what looks like a baseball league schedule, but it was not in a usable format.

Somehow this document got corrupted in the attach process.

More questions:

When you open this document on your device, does it look normal and behave normally?
Just to clarify, can you still print other documents, just not this one?
Was this file created on your mobile device, or created elsewhere and shared with you via email or one of the cloud storage services (Dropbox, Box or Google Drive)?
Do you share this document with other people?



I looked more carefully at the contents of the repaired document and realized it was a calendar. I did a SELECT ALL, COPY then opened a new excel spreadsheet and did a PASTE. The contents appeared quite nicely and I increased the size of the columns for legibility.

I wonder if this file will be printable from your mobile device. I’ve attached two copies of the file here, one as an XLSX formatted file, and the other as in XLS format.

Baseball_May.xlsx (11.0 KB)

Baseball_May.xls (23.5 KB)


I do greatly thank you for all the effort you have put into helping me with this issue. I downloaded the 2 files you sent and still the same thing. I can print in other applications but just not office smart 2. It seems there is a bug or problem in the app and I have concluded that it is an issue on your side. I have even created a new document in Office Smart and tried to print to no avail and have come to the decision to just use other apps. Thank you for everything you have done.


I’m sorry SO2 will not work with the HP Photosmart D110.

We have a list of over 7000 supported printer models, and sometimes SO2 works with printers that are not on the list, but not in all cases. The full list is here:

Thank you for working with us.

SmartOffice Support


The printer can stop suddenly that show It may because of it version. You have to change and download updated versions. We have a strong tech support team that you can contact to the printing error.


There is an issue with the HP Photoshop D110 which can troubleshoot after downloading a firmware from hp printer assistant and rebooting the printer.