SO won't open up


#1

A couple weeks ago Smart Office stopped working for me.

It boots through the opening welcome screen, then the screen you can choose to create, open, etc. And then in a second or less it bombs back to the iPad icon screen.

I have a fair amount of documents stored, and one with some $$$ numbers I’d really, really need to save out of this? Help! If I could just get that one document…

I didnt upgrade anything at all related to the iOS or Smart Office at the time this happened. I’ve do e the simple closing of programs, and iPad shutdown and restart.

I am running old versions, but I hesitate to upgrade stuff and really messing up at the moment! What can I do to recover my data?

Your old versions of software worked great for me, so I saw no need to upgrade. I’m scared to do so and lose my data… Is there some reset I can do to start with?

iPad iOS 7.1.1 on a iPad 4th generation

Smart Office i7901 2.1.20. 2013


#2

Hi Rambler.

I’m sorry to hear you are having trouble with SO.

You are very far behind in both iOS and SO2 updates, but it is curious that SO2 should stop working if you haven’t taken an update in either of them.

The first thing I’d like to check on is whether or not your iPad is synched with a desktop (or laptop) computer via iTunes. If it is, and you’ve taken a backup of your device, you’ll find a list of files created and/or saved by SO2 in the iTunes interface. Each of those files can be selected and saved to a location on your computer hard drive.

I’ll check to see if we’ve recorded any SO2 bugs with your iOS version and your iPad model.

Ron
SmartOffice Support


#3

Hi, I’m having the exact same problem as above, however I am on a iPad2 running 6.1.3 version. I have not done any updates either prior to this happening. I use this app a lot and it has been working fine until about 1 and a half weeks ago when I encountered the same issues as described above. I haven’t done a backup for a while, so there are important documents in this app that I really need to get access to. Your assistance would be very much appreciated.


#4

Hi TashaLee.

Rambler never responded to my post, so I don’t know what his situation is.

If you have taken backups in the past, I recommend first that you check the contents of your last backup via iTunes and see if you can see files stored on you device. If you can see stored files, highlight each and save to a location on your computer. Segregate these files in a folder on your computer.

Then take a new backup and check the contents of that backup for your files. If you see them, save to your computer and keep these separate from the previously saved documents.

The next step would be to get the most recent SO2 version, but I recommend you try to find and save your locally stored files first.

Ron
SmartOffice Support


#5

I am not tethered to a computer through iTunes, so I don’t think I have backups to access. I could do so, but I presume it would not matter at this point? I do have the iexpand thumb drive and made iPad backup through that device, but again I presume that is not an official backup and would not have caught your software?

My problem cropped up when I was fairly close to filling memory, tho I was not using your program that day, it is the only think outside of ordinary I can think of for that time period.

Thanks for following up with this, wherever it goes…

Paul


#6

Hi Paul.

Again, I am very sorry you are having trouble with SO2. I’m also sorry to hear you are not using iTunes to backup to a computer.

I’m having a hard time trying to explain what could be wrong if you haven’t upgraded either the operating system, and/or SO2.

Just to verify we’ve tried all the simple things, have you closed all the applications and rebooted your device? (That sometimes works miracles.)

Your guess about getting close to your device memory limit might be a plausible explanation. I wonder if you have any applications or files (music, photos, books) taking up resources that you could delete or offload to free up memory, then re-try SO2 to see if your documents are visible. If freeing up memory allows SO2 to run and you find your documents are still present, you could copy them to one of the free online file storage services (Dropbox or Google Drive). (I’m not sure if iCloud for backup/sync is an option with your operating system.)

I recommend you try to free up memory to try to start SO2. If it launches, the next step would be to copy your files to a cloud based location. If neither of these steps works, we can try more intrusive measures.

As you are aware, upgrading your operating system is not without risk. You may have applications running that won’t function under the latest operating system. Upgrading SO2 to current might be an option, but it is possible that doing so would over write your stored local files.

Ron
SmartOffice Support


#7

I just closed all programs (flicked up…) and turned off the iPad (held button, swiped it off, waited a minute, and startd it back up). I’ve done this several times, but did again.

I the. Tried to open SO, and it shows the version page, goes to the selection page and shuts right down. As it has been doing.

I then double clicked the main iPad button, and looked - it showed SO as the only program open, and it is displaying a PowerPoint slide show it opened with it last… Again, this is in the ‘turn off programs’ view of the iPad, while trying to run SO it never showed this…

A random thought - would a newish PowerPoint code hang up the older version of SO we are using?


#8

Paul, I don’t think one PowerPoint file would cause problems with the app. (If the app has trouble with a file type, the document would fail to open, but other documents would be ok.)

I think your lack of storage space on your device is a more promising avenue to explore. Are there any apps you can uninstall? Are there files you can move to cloud storage (photos, music, videos, e-books)?

With no changes to operating system or version of SO2, running out of storage space might explain why SO2 can no longer launch.

Ron
SmartOffice Support


#9

I got a drone and deal with video files at the beginning of the year.

I had about filled my 64gig iPad back when, but have shifted pic/video files many times, and now keep it with at least 10gig free space.

So, yes, I have deleted pics/vid and created room, I did so really the same day my iPad said it was about full, and have managed free space much better the past weeks.

I have not deleted other installed apps tho, only data.

Again, thanks for the follow ups, just trying to work this out as least destructively as I can. :wink: I’m willing to try stuff, and proceed slowly.


#10

Well, I found access to my files!

For the other person with this problem, I was playing around and suddenly, I was able to open and use Smart Office.

The key for me is to close out all programs (double click the iPad button and flick shut the open programs).

And then turn off all Internet access. (General and turn off wifi and cell.)

With Internet off, Smart Office will open up and work for me!

The trouble then is, getting my documents somewhere else safe, as I have no Internet… But anyhow, I can open and get to my files finally!

Paul


#11

Hi Paul.

Thanks for letting us know you found the files, and for letting us know how you found them.

I’m going to look into this as I’ve not heard of SO2 having trouble with wifi enabled and concurrent apps running. It sounds like a resource shortage.

Regarding getting copies of the local files, I recommend you email them to yourself. If wifi is off, outgoing messages should be stored for sending when wifi is enabled.

Ron
SmartOffice Support


#12

Hi Paul.

I checked with the engineers and they advise two things for you to do:

  1. Backup your device and files to a computer via iTunes.
  2. Upgrade to the current version of SmartOffice 2 (currently 2.3.21 for iOS)

Let us know whether or not this solves the problem.

Ron
SmartOffice Support