Unsupported Document Type Error


#1

We support 20+ Android tablets where we run the Smart Office 2 app. Typically, we have Excel sheets loaded into Dropbox for our field techs to access, fill out a checklist in Smart Office and re-save them to Dropbox. As of yesterday, one of my users is getting an "Unsupported Document Type error any time he tries to open one of the checklists. I can access the files on my desktop through Dropbox with no issue, which illustrates that the files themselves are fine. I tried the same with Google Drive and got the same error, which narrowed down my focus to the Smart Office App.

The odd thing is that there are 2 Excel sheets in the Dropbox account which will open and be editable. But there are approx 30 sheets that will not open. The tablet in question is running Smart Office 2.3.3. Seems like the issue has started with the recent update. Any tips?


#2

Hi Chapper,

Sorry to hear you’re having this problem. Is it possible you can share one of the spreadsheets that won’t open with us so we can investigate the problem? If so, you can email the file to smartoffice-forum@artifex.com

Thanks

Jogu


#3

E-mail sent with an example of one that gives the error and one which does not.


#4

Brilliant, thanks!

I can reproduce that problem here. I’ll pass it over to be investigated further, our internal tracking id for this is 695548.

I’ve noticed that the problem file is in the old binary .xls format - as a possible workaround, it might be worth trying to convert it to the newer xml based format - you can do this in MS Excel on the desktop by opening the file, then ‘save as’, and under format pick ‘excel workbook (.xlsx)’ or something similar - it varies slightly between versions.


#5

It is a problem in the .xlsx format as well.